Проект Синяя птица

Техническая поддержка решений проекта Синяя птица => Запуск и установка операционной системы => Тема начата: wall-e от 18 Январь 2012, 16:38:25



Название: Altair. Проблема в отображнии сайтов в локальной сети
Отправлено: wall-e от 18 Январь 2012, 16:38:25
Всем доброго времени суток. Проблема заключается в следующем: на втором компьютере не отображается сайт, который находится на альтаир.   

Ситуация: Два копьютера подключены между собой локально. Оба идут к адсл модему. На одном установлен альтаир, а на втором win7 x64. есть статический IP

На альтаире создаем сервер виртуальный для сайта с доменом и прочее. прописываем в hosts
Так же и на втором локальном. На альтаире создано три домена-сайта.

Но из трех отображается корректно только один на вин7 , при вводе адреса сайта. При вводе других двух адресов-отправляет к управлению модемом адсл. 

Что не так сделал или что еще нужно сделать для того чтобы в локальном втором вин7 все отображалось,а не отправляло к модему? Заранее благодарю.


Название: Re: Altair. Проблема в отображнии сайтов в локальной сети
Отправлено: admin от 19 Январь 2012, 13:38:22
Как обращаетесь к сайтам? Виртуальные хосты для других двух сайтов прописали в httpd.conf и hosts ?


Название: Re: Altair. Проблема в отображнии сайтов в локальной сети
Отправлено: wall-e от 19 Январь 2012, 16:07:26
в host прописал все. как на альтаире так и на винде.
В httpd.conf ни чего не прописывал.
На альтаире ввожу адрес сайта созданного на домене и все нормально. С винды так не получается. приходится через анонимайзер входить. иначе отправляет к настройкам модема. Ну а так с другой сети - все отображается и не перенаправляет ни на какой модем. Т.е. все работает как надо. но вот что и где ковырять чтобы в локальной то настроить все нормально.


Название: Re: Altair. Проблема в отображнии сайтов в локальной сети
Отправлено: AcetonKZ от 19 Январь 2012, 16:38:51
Поскольку в ближайшее время буду масштабно разворачивать подобное на альтаире, хотелось бы поподробнее чего и где прописали, где чего вводите(сдается мне ,что не без ДНС проблема)
ну и как к сайта обращаетесь? по каким именам?


Название: Re: Altair. Проблема в отображнии сайтов в локальной сети
Отправлено: wall-e от 19 Январь 2012, 16:51:55
домен оформляется у провайдера. управление к нему идет через сайт их же. прописиваю к демену запись А на мой IP собсно на котором и есть сервер альтаир. DNS я думаю присваивается т.к. нет ни какой строчки про него. Далее в альтаире создаю виртуальный сервер в котором и пишу домен. Затем в host альтаира и винды прописываю локальный IP сервера. Из трех домено отображается только один когда в вин ввожу адрес. т.е. домен остальные же отправляют к модему.


в хосте альтаира пишу его локальный IP - домен. В вин пишу IP локальный присвоеный альтаиру - домен

Если бы дело было в DNS на работу же прихожу и ввожу адреса сайтов у меня же все нормально отображается, ни куда не перенаправляет. ни на какие модемы и прочее. Я могу приложить необходимые скрины если надо и какие?


Название: Re: Altair. Проблема в отображнии сайтов в локальной сети
Отправлено: admin от 20 Январь 2012, 10:46:31
Вы что-то намудрили с файлом hosts или маршрутизацией на Виндовой машине, если из внешки сайты видны, а в локалке нет. Возможно, на виндовой машине надо добавить маршрут на сервер


Название: Re: Altair. Проблема в отображнии сайтов в локальной сети
Отправлено: wall-e от 20 Январь 2012, 11:36:51
в host альтаира следующие записи 192.168.0.8   f1.tom.ru

в win7 host     192.168.0.8   f1.tom.ru

У альтаир настроена  сеть следующими параметрами   
IP 192.168.0.8
маска 255.255.255.0
шлюз 192.168.0.1

И прописаны ДСН сервера

Подключение сетевого моста. т.к. стоит какой то умны блок системный в котором при установке ОС, производится запрос-какого типа будет подключение. Есть варианты NAT, сетевой мост и еще что то... сейчас не вспомню. МОжет быть тип подключения не тот?! хотя работает же все.




Название: Re: Altair. Проблема в отображнии сайтов в локальной сети
Отправлено: AcetonKZ от 20 Январь 2012, 12:28:27
Цитировать
Если бы дело было в DNS на работу же прихожу и ввожу адреса сайтов у меня же все нормально отображается, ни куда не перенаправляет. ни на какие модемы и прочее
Стоп!
Похоже у меня тоже такое было, правда сервак (Альтаир) на виртуалке крутится, но с отделным локальным выделенным IP-адресом. При попытке достучаться к нему из основной ОС (СпаркКрафт) тоже видел потрох модема.
Проблема в том, что у меня АДСЛ модем-роутер, в котором настроена проброска портов из АДСЛ(т.е. WAN по отношению к моей сети) на айпи моего виртуальног сервера ,а при обращении из локалки(т.е. из основной системы, с другим, но локальным, IP-адресом) модем никакой проброски не осуществляет, а тупо выдает свой вэб-интерфейс.

Вылечилось прописыванием алиасов как на альтаире(чтоб и вордпресс работал, и др части сайта) так и на спарккрафте.

Почему вин7 тупо игнорирует прописаный алиас - вопрос к дяде гейтсу ;) видимо

Цитировать
Подключение сетевого моста. т.к. стоит какой то умны блок системный в котором при установке ОС, производится запрос-какого типа будет подключение. Есть варианты NAT, сетевой мост и еще что то... сейчас не вспомню. МОжет быть тип подключения не тот?!
А вот про это подробнее где и чего стоит и спрашивает?


Название: Re: Altair. Проблема в отображнии сайтов в локальной сети
Отправлено: wall-e от 20 Январь 2012, 12:46:24
Про алиасы бы подробнее. в модеме вроде бы прописывал путь к альтаиру.

Про то что где стоит: сис.блок в чистом (без ОС) состоянии просит выбрать тип адаптера и подключения. мне это напомнило как виртуалбокс. НО это дело в шито в саму мат.плату похоже. потом уже обращается к диску установочному ОС.

Как бы проблем то не было с другими ОС. но вот альтаир так вот. Хотя если честно сервера ни разу на базе линукс не устанавливались на эту машину.
У меня просто подозрение давно,что там вшита виртуальная машина и с ней вот проблема


Название: Re: Altair. Проблема в отображнии сайтов в локальной сети
Отправлено: AcetonKZ от 20 Январь 2012, 12:53:21
Цитировать
мне это напомнило как виртуалбокс.
Мне тоже ;)
Цитировать
Про алиасы бы подробнее. в модеме вроде бы прописывал путь к альтаиру.
Ну ,это две отдельные темы, если коротко, то
1. Port Forwarding у меня стоит на 192.168.0.200 - IP моего "виртуального" альтаира. На этот IP, зарезервированый для него идет проброска порта 80(80?) по правилу "Вэб сервер". Никаких более портов туда не пробрасывается, DMZ нет. Сам модем традиционно 192.168.0.1, СпаркКрафт 192.168.0.2. Это что касается модема
2.если доменов несколько(3?), то прописывать похоже надо тоже 3 алиаса?! У меня прописано так в обоих системах: 192.168.0.200 librefind.dyndns.org
Цитировать
У меня просто подозрение давно,что там вшита виртуальная машина и с ней вот проблема
Вполне может быть ???
Что за мать то? Из новых?
На ней стоит винда или альтаир?


Название: Re: Altair. Проблема в отображнии сайтов в локальной сети
Отправлено: wall-e от 20 Январь 2012, 13:06:01
Цитировать
Вполне может быть ???
Что за мать то? Из новых?
На ней стоит винда или альтаир?

Xeon E5506 (2.13 GHz), 4GB, 4x1TB Материнская плат Intel S5500BC  На нем стоит альтаир теперь.

ТАкс. про алиасы я честно говорю-ни чего не знаю.где и как и куда их втыкать. Да доменов несколько.


Название: Re: Altair. Проблема в отображнии сайтов в локальной сети
Отправлено: AcetonKZ от 20 Январь 2012, 13:09:30
 
Цитировать
про алиасы я честно говорю-ни чего не знаю.где и как и куда их втыкать. Да доменов несколько
В hosts нужно прописать все три алиаса на один IP(я  бы так делал):
   192.168.0.200 сайт1.домен.ру
   192.168.0.200 сайт2.домен.ру
   192.168.0.200 сайт3.домен.ру

если домены разные, то так
   192.168.0.200 сайт.домен1.ру
   192.168.0.200 сайт.домен2.ру
   192.168.0.200 сайт.домен3.ру

Цитировать
Материнская плат Intel S5500BC
Эта? (http://www.nix.ru/autocatalog/motherboards_intel/INTEL_S5500BCR_Dual_LGA1366_i5500_2xGbLAN_SATA_RAID_8DDRIII_96856.html)

Так там же две карты сетевые. Видимо это режим их совместной работы спрашивается, хотя, честно, с такими серверными мамками дел пока не имел... Может проще воткнуть дискретную сетевуху? ;)
А спрашивает инсталяшка, или БИОС?


Название: Re: Altair. Проблема в отображнии сайтов в локальной сети
Отправлено: wall-e от 20 Январь 2012, 13:23:41
именно так и прописано в хостах. Как на альтаире так и на виндовс. на каждый домен прописываю.

Может проще будет дат скрины или эти хосты? только как дома буду. В интернете подобного мало нашел, но в основном ситуации схожие,но между виндовсами,а не виндовс линукс. И поэтому сложно сказать и сделать для меня что то. Малые знания тоже дают знать. Просто кажется, что в альтаир чего то не сделал. Вот только что понять бы. обращается нормально только к одному из доменов что первый в списке. к остальным только из вне или же через прокси. Но делать сайты так не удобно вообще ни как.


Название: Re: Altair. Проблема в отображнии сайтов в локальной сети
Отправлено: AcetonKZ от 20 Январь 2012, 13:27:05
Я как понимаю, все три домена вертятся на одной машине как виртуалхосты апача?
Цитировать
но в основном ситуации схожие
Т.е. вин7 тупо игнорирует множественный алиас?
Цитировать
На альтаире создаем сервер виртуальный для сайта с доменом и прочее.
Это цитата из первого поста. можно подробнее где чего и как создаем.
Цитировать
Но делать сайты так не удобно вообще ни как.
а тупо обращаться напрямую по IP никак, т.к. у всех трех доменов(что именно вы имеете в виду под словом домен?) один IP? Так?


Название: Re: Altair. Проблема в отображнии сайтов в локальной сети
Отправлено: wall-e от 20 Январь 2012, 13:33:23
БИОС спрашивает. я хз как он узнает что нет ОС в системе ))

Да. Все три домена на одной. и как виртуалхосты. ну создавал их через вебмин и прописывал в хост.

И вин7 похоже игнорирует, но кажется все дело в альтаире. В каком то пункте или настройке


Название: Re: Altair. Проблема в отображнии сайтов в локальной сети
Отправлено: AcetonKZ от 20 Январь 2012, 13:40:32
Цитировать
но кажется все дело в альтаире.
Если это виртуалхосты апача - то альтаир тут ни при делах скорее всего, дело, возможно в апаче. хотя трудно оценить ситуацию заочно ???
Тут  (http://forum.searchengines.ru/archive/index.php/t-447902.html) нагуглилось такое:
Цитировать
Apache по ip-адресу будет выдавать сайт, который указан первым в его конфигурации.


Название: Re: Altair. Проблема в отображнии сайтов в локальной сети
Отправлено: wall-e от 20 Январь 2012, 14:06:08
могу предоставить скрины все. Так же можно и по ICQ или Scype


Название: Re: Altair. Проблема в отображнии сайтов в локальной сети
Отправлено: AcetonKZ от 20 Январь 2012, 14:21:50
Видимо это не апач :( надо еще гуглить
Если из WAN все конектится, и с альтаира тоже, то явно вин7  с алиасами дуркует


Название: Re: Altair. Проблема в отображнии сайтов в локальной сети
Отправлено: wall-e от 20 Январь 2012, 14:27:06
Если бы дело в апаче.То вообще бы не работало я так думаю.Я два домена из трех не вижу локально, а из вне все нормально.


Название: Re: Altair. Проблема в отображнии сайтов в локальной сети
Отправлено: AcetonKZ от 20 Январь 2012, 14:41:05
Если вылазиет потрох модема, то дело явно в алиасах в вин7 и альтаир тут ни причем.
При запросе из WAN модем-роутер и альтаир(апач) все обрабатываю верно, значит неверен запрос к ним.
Как вариант - поменять последоватеьность перечисления алиасов.
По идее, если дело в них, то должно измениться поведение системы.
Из самого Альтаира пробовали обращаться ко все доменам?


Название: Re: Altair. Проблема в отображнии сайтов в локальной сети
Отправлено: wall-e от 20 Январь 2012, 15:02:54
Из алтаира конечно пробовал. Все работает как надо. Хорошо. попробую значит смотреть настройки модема и разбираться в вин7. Спасибо


Название: Re: Altair. Проблема в отображнии сайтов в локальной сети
Отправлено: AcetonKZ от 20 Январь 2012, 15:18:16
модем, как я думаю, настроен правильно. копайте под вин7 ;)
Кстати, и альтаир и вин7 имеют статические адреса или DHCP?
И что пропис-ано(-ывается) в качестве ДНС серверов на обоих тачках?


Название: Re: Altair. Проблема в отображнии сайтов в локальной сети
Отправлено: wall-e от 20 Январь 2012, 15:52:28
стоит адсл модем. Статический IP адрес. от модема к двум машинам провода. на вин7 адрес 192,168,1,25 а на альтаире 192,168,1,8 локальные адреса. в ДСН пропсианы значения указанные провайдером. в сетевых настройках/


Название: Re: Altair. Проблема в отображнии сайтов в локальной сети
Отправлено: wall-e от 20 Январь 2012, 16:00:58
чтож. все решилось. очистил в файле хост на вин7 все записи. перезагрузился. система содала сама запись необходимую есть локалхоста. затем я снова прописал домены в нем. И странно-работает. Но почему так?! систему и перезагружал и чего только не копал. Пока не удалил все с хоста.

Всем спасибо за помощь. Большое спасибо.


Название: Re: Altair. Проблема в отображнии сайтов в локальной сети
Отправлено: AcetonKZ от 20 Январь 2012, 22:45:03
"А ларчик просто открывался"
Как всегда нужно было "переустановить" винду ;)
Успехов.


Название: Re: Altair. Проблема в отображнии сайтов в локальной сети
Отправлено: wall-e от 21 Январь 2012, 02:48:56
ну вроде того.надеюсь,что кому то пригодится.мало ли.встречались подобные проблеммы


Название: Re: Altair. Проблема в отображнии сайтов в локальной сети
Отправлено: AcetonKZ от 21 Январь 2012, 09:13:49
офф:
думаю, что для проекта в целом было бы неплохо в разделе "железо" рассписать на каком именно железе что работает, а что нет, какие возникали трудности.