Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
19 Ноябрь 2017, 08:57:31
Новости:

Страниц: [1] 2 3   Вниз
Печать
Автор Тема: Как установить драйвер видеокарты ATI/AMD? (руководство)  (Прочитано 43366 раз)
0 Пользователей и 1 Гость смотрят эту тему.
admin
Знания не сила, сила - это воля и умение применить знания
Администратор
Бог
*****

Карма: +226/-23
Offline Offline

Пол: Мужской
Сообщений: 2142


Главный


WWW
« : 06 Октябрь 2009, 22:37:34 »

Внимание! Данное руководство - это скорее шпаргалка для специалистов, а вовсе не руководство для новичков. Если Вы не в курсе, что такое X-сервер, xorg.conf и драйвер, то мы рекомендуем Вам воспользоваться услугами специалистов во избежание неприятных сюрпризов,  к примеру, службой технической поддержки нашей компании или помощью друзей.

Самый простой способ установки драйверов - воспользоваться услугами специалистов, или попросить знакомого хакера.

Если Вы хотите установить драйверы самостоятельно, то Вам подойдут следующие способы
Автоматический способ установки драйверов - при активном Интернет подключении запуск утилиты Главное меню -> Система -> Устройства -> Драйверы устройств. Программа автоматически обнаружит, скачает и установит необходимые драйверы из локального репозитория или из Интернет(Ubuntu). Главным минусом такого подхода является тот факт, что репозиторий содержит не самые новые версии драйверов, а в новых версиях исправляются ошибки и добавляются новые возможности.

Самый гибкий способ установки проприетарного драйвера - вручную.
1. Скачать последний пакет драйвера для ядра Linux с сайта производителя amd.ru(или с установочного диска /bluebird) в домашний каталог /home/Ваше_имя/drv/ (временную папку для распаковки - drv необходимо сперва создать)
2. Перейти в каталог с пакетом драйвера - выполнить в терминале cd /home/Ваше_имя/drv/
3. Переименовать пакет драйвера на "drv.run" (без кавычек) и выполнить в терминале команду sudo sh drv.run --buildpkg Ubuntu/lucid (lucid замените на кодовое обозначение репозитория Ubuntu Вашего дистрибутива) чтобы создать DEB-пакеты для установки в системе Синяя птица 10. Внимание! команда потребует ввода пароля администратора. Для 10 серии систем (2010 года) кодовое обозначение репозитория - lucid.
4. Установить все сгенерированные в этом каталоге DEB-пакеты, учитывая взаимные зависимости. (sudo dpkg -i *.deb или открыть с помощью GDebi)
5. Выполнить sudo gedit /etc/X11/xorg.conf (Содержание xorg.conf по умолчанию)
6. Найти в открывшемся файле секцию и добавить/исправить выделенную строчку
Section "Device"
   Identifier   "SOME IDENTIFIER"
   Driver      "fglrx"
EndSection
7. Сохранить изменения в этом файле (Ctrl+S)
8. Выполнить в терминале sudo aticonfig --initial -f
9. Перезагрузите компьютер

ПРИМЕЧАНИЕ: Если X-сервер не желает использовать драйвер после перезагрузки, переключите его в ручной режим заклинанием sudo dpkg-reconfigure -phigh xserver-xorg, создайте файл xorg.conf и укажите в нём явно
Driver      "fglrx"

Полное руководство прикреплено во вложении данной темы (просмотр доступен только зарегистрированным пользователям)...

!Внимание! Начиная со сборки системы Синяя птица 2009.7 проприетарный драйвер включён в поставку. Готовые к установке в систему пакеты драйвера находятся на установочном диске в папке /bluebird
« Последнее редактирование: 25 Февраль 2011, 17:42:46 от admin » Записан

GDA
Новичок
*

Карма: +0/-0
Offline Offline

Сообщений: 4


« Ответ #1 : 04 Июнь 2010, 19:59:27 »

При автоматическом способе установки: идёт сначала поиск потом появляется окно "Драйвера устройств" написано "проприетарные драйверы устройств не используются в вашей системе" Я что то не так делю?
Вручную пробовал несколько раз, не получилось даже потом система загружаться отказывалась.
Записан
admin
Знания не сила, сила - это воля и умение применить знания
Администратор
Бог
*****

Карма: +226/-23
Offline Offline

Пол: Мужской
Сообщений: 2142


Главный


WWW
« Ответ #2 : 04 Июнь 2010, 20:21:43 »

При автоматическом способе установки: идёт сначала поиск потом появляется окно "Драйвера устройств" написано "проприетарные драйверы устройств не используются в вашей системе" Я что то не так делю?
Вручную пробовал несколько раз, не получилось даже потом система загружаться отказывалась.
Значит совместимых с Вашей видеокартой проприетарных драйверов просто нет. Обратитесь к производителю вашей видеокарты с вопросм - "Почему их нет?"
Записан

GDA
Новичок
*

Карма: +0/-0
Offline Offline

Сообщений: 4


« Ответ #3 : 04 Июнь 2010, 21:11:43 »

Интересно, до этого ставил дистр. Runtu, он при первой загрузке - "бла, бла, настройте систему, вам нужно загрузить драйвер проприетарный" скачал установил, интересно откуда он его взял.
http://support.amd.com/us/gpudownload/linux/Legacy/Pages/radeon_linux.aspx?type=2.4.1&product=2.4.1.3.16&lang=English
вот здесь драйвер есть(radeon x800 у меня)
Записан
admin
Знания не сила, сила - это воля и умение применить знания
Администратор
Бог
*****

Карма: +226/-23
Offline Offline

Пол: Мужской
Сообщений: 2142


Главный


WWW
« Ответ #4 : 04 Июнь 2010, 22:01:14 »

Этот проприетарный драйвер давно устарел и не совместим с новой версией X сервера.
У Вас есть несколько возможных вариантов:
1) Единственный вариант для Вас в новых системах - это использовать свободный драйвер, идущий в комплекте с системой
2) Пользуйтесь старыми сборками, где старая версия X сервера, совместимая с этим старым драйвером
3) Купите новую видеокарту, для которой AMD/ATI выпускают драйверы и пользуйтесь новыми системами со всеми возможностями новой карты
4) Можно пользоваться WinXP, для которой есть драйвер на Вашу видеокарту
« Последнее редактирование: 04 Июнь 2010, 22:05:46 от admin » Записан

Feniks
Новичок
*

Карма: +2/-0
Offline Offline

Сообщений: 9


« Ответ #5 : 05 Июль 2010, 12:57:05 »

Возникла проблема.Синяя птица 10.2.Видео ASUS EAH3650 Series.После установки ОС запустил проприетарные драйверы устройств.Утилита нашла драйвер,скачала все нормально.Сегодня система попросила скачать обновления.Скачал,обновил.Исчезли все 3D эффекты раб.стола.При обновлении драйвера выдает ошибку.Как это исправить?
Записан
admin
Знания не сила, сила - это воля и умение применить знания
Администратор
Бог
*****

Карма: +226/-23
Offline Offline

Пол: Мужской
Сообщений: 2142


Главный


WWW
« Ответ #6 : 05 Июль 2010, 13:07:54 »

Скорее всего драйвер отключился из-за обновления ядра системы (linux), дело в том, что разработчики драйвера статически привязывают драйвер к конкретной версии ядра, и в случае обновления, требуется перекомпиляция модулей драйвера. Самый простой вариант для Вас - это удалить драйвер из системы полностью, а затем установить его снова.
Записан

zom900
Новичок
*

Карма: +1/-0
Offline Offline

Сообщений: 6


« Ответ #7 : 08 Июль 2010, 11:51:12 »

Цитата от сюда: http://integra-l.ru/site/index.php/bluebird/spark
Цитировать
# Отличается невысокими по сравнению с Windows Vista/7 аппаратными требованиями и более высоким быстродействием системы
# Обеспечивает лучшую поддержку оборудования. Причём, поддерживается даже устаревшие устройства
Моё железо Authlon 2600+ /2Gb/VIA KT600/ AGP ATI x1300 pro 256 DDR2/
Система Искра 10.3
Тормоза нереальные... Sacred for Linux - Тормозит! Даже Heroes of Might and Magic 3 for Linux в режиме Full Screen тормозит! Непонимающий
За запуск игр для Windows из Wine или PlayOfLinux вообще говорить не приходится... Либо зависают, либо дают ужасные искажения...
Где найти драйвер для видео и как его поставить? Ведь наверняка есть неофициальные дрова какие нибудь???
Еще тормозов добавляет установка Adoube Flash Player 10 версии... Видео с tnt-online и прочих сайтов смотреть стало смотреть возможно только скрипя зубами Рот на замке
Некоторые сайты подвисают FireFox секунд на 30-50 из за флеш анимации...
Это связано с отсутствием путевых дров на видео или можно от куда нибудь установить альтернативный плеер или более старую версию?

Под управлением Windows Vista/7 на своем железе я таких проблем не испытывал Грустный Это можно как то исправить или нужно ставить какой нибудь Ubunty 7.04 или более древнюю версию для комфортной работы как в Windows?? Непонимающий
Записан

admin
Знания не сила, сила - это воля и умение применить знания
Администратор
Бог
*****

Карма: +226/-23
Offline Offline

Пол: Мужской
Сообщений: 2142


Главный


WWW
« Ответ #8 : 08 Июль 2010, 11:59:23 »

1) Ваша видеокарта не соответствует минимальным требованиям комфортной работы в системе (см. описание на сайте), вот если была хотябы X1600, тогда многих проблем у Вас не было бы...
2) К тому же, для Вашей, уже давольно давно устаревшей, видеокарты не найти драйвер от AMD|ATI под современные версии Xorg. Вам остаётся лишь пользоваться свободными драйверами... Либо установить какой-нибудь древний дистрибутив (Ubuntu 8.04/8.10, например) с подходящей версией Xorg и поставить устаревшие (9.3, кажется) дрова от AMD|ATI.
« Последнее редактирование: 08 Июль 2010, 12:04:59 от admin » Записан

zom900
Новичок
*

Карма: +1/-0
Offline Offline

Сообщений: 6


« Ответ #9 : 08 Июль 2010, 12:16:32 »

Вам остаётся лишь пользоваться свободными драйверами...
Свободный драйвер - это тот что стоит по умолчанию?

Цитировать
Либо установить какой-нибудь древний дистрибутив (Ubuntu 8.04/8.10, например) с подходящей версией Xorg и поставить устаревшие (9.3, кажется) дрова от AMD|ATI.
Обидно Обеспокоенный
Записан

admin
Знания не сила, сила - это воля и умение применить знания
Администратор
Бог
*****

Карма: +226/-23
Offline Offline

Пол: Мужской
Сообщений: 2142


Главный


WWW
« Ответ #10 : 08 Июль 2010, 12:34:01 »

Свободные драйверы встроены в систему.
Сочувствую Вам, но такова политика AMD|ATI - для старых карт они отказываются делать новые драйверы. Сам сижу на X1950GT и пользуюсь свободными дровами от безысходности Улыбка
« Последнее редактирование: 08 Июль 2010, 12:36:56 от admin » Записан

sudo_su
Новичок
*

Карма: +0/-0
Offline Offline

Сообщений: 2


« Ответ #11 : 07 Август 2010, 23:10:15 »

Можно просто набрать в терминале sudo sh имя драйвера.run =) там же есть графический инсталятор
Записан
dmitry287
Новичок
*

Карма: +5/-0
Offline Offline

Сообщений: 21


« Ответ #12 : 19 Август 2010, 23:09:14 »

Цитировать
Сам сижу на X1950GT и пользуюсь свободными дровами от безысходности
Они и для новых карточек кривые дрова для линукса делают,на всех форумах про это пишут.Пробую каждую версию которая выходит,и каждый раз возвращаюсь на коробочные, на фильмах в динамичных сценах получаются горизонтальные изломы изображения,причем не только на HD. Перечитал кучу форумов,перебробывал все настройки и версии дров и плэйеров которые выходили за последнее время,ничего не помогло. На открытых дровах такого нет,поэтому на них и сижу.
« Последнее редактирование: 19 Август 2010, 23:11:56 от dmitry287 » Записан
Xboxgame
Новичок
*

Карма: +1/-0
Offline Offline

Сообщений: 6


« Ответ #13 : 13 Сентябрь 2010, 05:12:01 »

Ни в какую не могу установить драйвер на radeon hd 5750 в Искре 10.3,в Синей птице 10.3 драйвера скаченные с оф.сайта устанавливаются,а вот в искре после установки и перезагрузке выдаёт ошибку. Если устанавливаю через драйвера устройств, то в списке драйвер есть,но при установке появляется ссылка на какой то сайт. Как быть?
Записан
admin
Знания не сила, сила - это воля и умение применить знания
Администратор
Бог
*****

Карма: +226/-23
Offline Offline

Пол: Мужской
Сообщений: 2142


Главный


WWW
« Ответ #14 : 13 Сентябрь 2010, 11:23:16 »

Скорее всего драйвер из репозитория Вам не подходит, т.к. он очень старый. Вам нужен актуальный драйвер, который поддерживает Вашу модель видеоадаптера. В разделе ЧаВо есть инструкция по установке. Также Вы можете немного подождать Искру 10.4, образ будет доступен для скачивания сегодня или завтра, там уже драйверы свежие.
Записан

Страниц: [1] 2 3   Вверх
Печать
 
Перейти в:  

Powered by SMF 1.1.21 | SMF © 2006-2009, Simple Machines

Страница сгенерирована за 0.098 секунд. Запросов: 20.