Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
27 Апрель 2018, 02:48:13
Новости:

Страниц: [1]   Вниз
Печать
Автор Тема: (Решено)Проблема при установке nvidia драйвера  (Прочитано 11825 раз)
0 Пользователей и 1 Гость смотрят эту тему.
msk
Интересующийся
**

Карма: +7/-0
Offline Offline

Сообщений: 72


« : 01 Октябрь 2012, 22:00:11 »

Уважаемый admin здравствуйте! Скажу сразу, что прошел по всевозможным форумам, но решения возникшей проблемы не нашёл, буду признателен Вам, если вы мне поможете. Прочитал на сайте NVIDIA, что в новой версии NVIDIA-Linux-x86_64-304.51.drv были устранены проблемы для моей видеокарты GeForce GT 240, скачал, поставил по Вашему руководству в разделе ЧаВо руками, всё встало, запустилось как по нотам. Решил сразу же посмотреть установленную версию с помощью NVIDIA X Server Settings , но не тут-то было: вместо ожидаемой мной картинки получил следующее   и выскочило You do not appear to be using the NVIDIA X driver.  Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server. . Предлагают мне подкорректировать xorg.conf, я правильно понимаю? Но я не знаю, что там надо править.
Попробовал cat /proc/cat/version, говорит, нет такого файла или каталога Подскажите, пожалуйста, что надо сделать, чтобы NVIDIA X Server Settings в поле слева выдал все позиции с информацией?
Вот мой xorg.conf на всякий случай

Section "Device"
   Identifier   "Default Device"
        Driver          "nvidia"
         Option   "NoLogo"   "True"
EndSection

Section "Screen"
        Identifier       "Default Screen"
        DefaultDepth     24
EndSection

Section "Module"
        Load              "glx"
EndSection
« Последнее редактирование: 16 Октябрь 2012, 16:43:18 от admin » Записан
admin
Знания не сила, сила - это воля и умение применить знания
Администратор
Бог
*****

Карма: +226/-23
Offline Offline

Пол: Мужской
Сообщений: 2142


Главный


WWW
« Ответ #1 : 02 Октябрь 2012, 17:46:36 »

Утилита nvidia сама сгенерирует необходимый xorg.conf, вам надо только запустить её от имени суперпользователя
Записан

Zhook
Постоялец
***

Карма: +20/-0
Offline Offline

Сообщений: 137


« Ответ #2 : 02 Октябрь 2012, 18:06:04 »

Просто выполните в терминале:
Код:
sudo nvidia-xconfig
Записан
msk
Интересующийся
**

Карма: +7/-0
Offline Offline

Сообщений: 72


« Ответ #3 : 03 Октябрь 2012, 00:54:44 »

Большое спасибо за отзывчивость, проделал sudo nvidia-xconfig, получил:
Using X configuration file:"/etc/X11/xorg.conf"
Backed up file /etc/X11.xorg.conf as /etc/X11/xorg.conf.backup
New X configuration file written to `/etc/X11/xorg.conf`

но после запуска NVIDIA X Server Settings получил ту же картинку, что представил выше и с той же надписью You do not appear to be using the NVIDIA X driver.  Please edit your X .....
You do not appear to be using the NVIDIA X driver.  Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server.. Тогда перезапустил Х-сервер: Ctrl+Alt+F1 ,  sudo service lightdm stop, sudo service lightdm start, почему-то изменились параметры разрешения экрана, теперь всё увеличилось в размерах и не помещается на экране. Тогда попробовал изменить порядок действий: перезагрузился, сразу  Ctrl+Alt+F1, остановил Х-сервер, затем sudo nvidia-xconfig, получил тот же ответ и перезапустил Х-сервер. Ничего не поменялось. Попробовал перезагрузиться в режиме восстановления, но процесс остановился на следующем: (==) Using system config directory "/usr/share/X11/xorg.cjnf.d" Можно, конечно, попробовать переустановить заново драйвер, но вряд ли это добавит мне знаний. Подожду лучше от вас подсказки.
Записан
dimka
Интересующийся
**

Карма: +10/-1
Offline Offline

Пол: Мужской
Сообщений: 60


« Ответ #4 : 03 Октябрь 2012, 16:17:39 »

либо автоматом в драйверах устройств,по пути система-устройства-дополнительные драйвера или драйверы устройств или ещё както называется незнаю найдёшь,или вот http://startubuntu.ru/?p=104169
Записан

Ноут Toshiba satellite L755-16u, HM65
Биос Обычный не UEFI
Проц Intel Core i5-2410M 2.3-2.9 Sandy Bridge
Память 6GB DDR3 1333
Видеокарта 1 Nvidia GeForce GT 525M 2GB
Звук Conexant Cx20585 и NVIDIA GF108 HDA
Сеть Gigabit Atheros AR8151 NDIS 6.20, WiFi Atheros AR9002WB-1NG/AR9285
msk
Интересующийся
**

Карма: +7/-0
Offline Offline

Сообщений: 72


« Ответ #5 : 05 Октябрь 2012, 19:46:07 »

Если докопаюсь, то выложу алгоритм решения, если нет, то принятое решение.
Записан
admin
Знания не сила, сила - это воля и умение применить знания
Администратор
Бог
*****

Карма: +226/-23
Offline Offline

Пол: Мужской
Сообщений: 2142


Главный


WWW
« Ответ #6 : 06 Октябрь 2012, 11:10:02 »

А Вы активировали механизм использования файла xorg.conf для Xсервера командой sudo dpkg-reconfigure -phigh xserver-xorg?
Без этого какой бы Вы файл не создавали, он не будет использоваться для конфигурации дисплейного сервера.
Записан

msk
Интересующийся
**

Карма: +7/-0
Offline Offline

Сообщений: 72


« Ответ #7 : 07 Октябрь 2012, 01:38:59 »

Нет, этого не сделал из-за незнания. Сейчас попробую. Но теперь перестала загружаться система, загружается только в режиме восстановления. В системном журнале обнаружил следующее:
07.10.12 00:28:15   msk-desktop   gdm-binary[986]   WARNING: Unable to find users: no seat-id found,
07.10.12 00:28:15   msk-desktop   gdm-simple-slave[1087]   WARNING: Unable to load file '/etc/gdm/custom.conf': Нет такого файла или каталога
 07.10.12 00:30:51   msk-desktop   avahi-daemon[948]   No service file found in /etc/avahi/services.
 07.10.12 00:34:03   msk-desktop   gdm-simple-slave[1324]   WARNING: Unable to load file '/etc/gdm/custom.conf': Нет такого файла или каталога
Не знаю, нужна ли эта информация, на всякий случай выкладываю.Спасибо!
« Последнее редактирование: 07 Октябрь 2012, 02:07:39 от msk » Записан
msk
Интересующийся
**

Карма: +7/-0
Offline Offline

Сообщений: 72


« Ответ #8 : 07 Октябрь 2012, 02:19:41 »

Проделал: sudo dpkg-reconfigure -phigh xserver-xorg
                     sudo nvidia-xconfig
Пишет, что New X configuration file written to '/etc/X11/xorg.conf', но NVIDIA X Server Settings продолжает выдавать старое
Записан
msk
Интересующийся
**

Карма: +7/-0
Offline Offline

Сообщений: 72


« Ответ #9 : 14 Октябрь 2012, 21:49:39 »

Наконец-то проблему свою я решил, а решилась она так: предположил, что виной всему Compiz и пока ни скачал на флэшку и ни переустановил файлы: compiz, compiz-plugins, compizconfig-settings-manager, compiz-gnome, compiz-core всё версии 0.9.7.8 и compizconfig-backend-gconf версии 0.9.5.92 ничего не помогало. Все пакеты на http://packages.ubuntu.com/  Оставляю тему, может кому-нибудь пригодится. Уважаемый, admin, не знаю, как добавить в названии темы (Решено), исправьте, пожалуйста, эту мою оплошность. Спасибо!
« Последнее редактирование: 14 Октябрь 2012, 22:09:59 от msk » Записан
Страниц: [1]   Вверх
Печать
 
Перейти в:  

Powered by SMF 1.1.21 | SMF © 2006-2009, Simple Machines

Страница сгенерирована за 0.118 секунд. Запросов: 20.